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STN Express® – Frequently Asked 
Technical Questions 

 
 
 

This document answers the most frequently asked  
technical questions related to STN Express. 

 
 

 
 
Notes:  

• Support for Macintosh versions of STN Express was discontinued as of 31, December 2007.  

• Support for versions of STN Express older than V8.4 was discontinued as of 10, June 2013.  

• Please contact the Help Desk at your local STN service center for help transitioning to a 
supported STN interface. 

• For additional technical support, contact the CAS Customer Center. 

 
  

http://www.cas.org/contact-us/cas-customer-center
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How can I find the exact version of STN Express?  
Launch the application and navigate to the location shown below: 

 
 

 

 
This process works on any supported version of STN Express. 
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Which STN Express Installer should I use? 
STN Express 8.6 offers two installer options. In many cases, you can choose either option. 

 None 
(New Installation) 

Upgrading from version 
8.3 or 8.4 

Upgrading from version 
8.2 or earlier 

MSI (v8_5msi.exe) 
[MSI Installer] 

   

EXE (v8_5.exe) 
[Scripted Installer] 

   

 
 

Note: 

About MSI installer (v8_6msi.exe)  

The MSI (Windows Microsoft Installer) is recommended for new installations and upgrades from STN 
Express 8.3 or later versions. Powered by an installer engine that is part of all recent versions of Microsoft 
Windows, it should have a very familiar look and feel, since MSI installers are widely used for installing 
software. It is compatible with Windows XP, Windows Vista, Windows 7, Windows 8 & 8.1 and Windows 
10.   

MSI installers power 60-70% of software installations. They are requested by customers who have central 
software distribution, such as Microsoft Active Directory. Customizing an installation to the needs of a 
particular company is easier with MSI. 

About Scripted installer (v8_6.exe) 

This is the STN Express classic installer. It must be used to upgrade from STN Express 8.2 or earlier. It is 
compatible with Windows XP, Windows Vista, Windows 7, Windows 8 & 8.1 and Windows 10.   

For those who have installed versions of STN Express before the development of the MSI installer, it will 
have a familiar look and feel. 
 

Upgrades from STN Express 8.2 or earlier 

The STN Express 8.6 Scripted installer is strongly recommended for this task. It preserves and 
copies user files and folders from version 8.2 or older versions to new locations in:  

• Windows 2000 and XP: C:\Documents and Settings\Username\My Documents\STN Express 8.6\  

• Vista: C:\Users\Username\Documents\STN Express 8.6\  

• Windows 7 and newer: C:\Users\Username\My Documents\STN Express 8.6\  

The Scripted installer uninstalls STN Express 8.2 or earlier, and removes the STN Express related *.ini 
files from C:\Windows.  

The MSI installer does not uninstall prior version software and is not recommended for upgrading STN 
Express 8.2 or for earlier versions. You may manually uninstall prior versions after the STN Express 8.6 
installation has completed.  
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How do I create an STN logon setup? 
The STN Express logon dialog box contains the information required to connect to a host server and 
begin a working session.  

To create a logon setup for STN:  

1. Click Setup on the main toolbar, and then choose STN Setup Wizard.  

 

2. If necessary, click the radio button to select the appropriate STN International Service Center. 

3. If necessary, enter the Logon Port. (Most customers use X for the Login Port. Your startup kit 
provides information on whether you should use a different port.)  
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4. Click Next.  

5. Choose the type of connection.   

Note: Connections to non-STN hosts must be defined manually, see the How can I modify or 
create an STN Express logon setup? section. 

 

Connection descriptions: 

• Internet Connection – This is the most common type of connection.  It connects through 
your Local Area Network (LAN) and relies on being able to make a telnet connection (via 
port 23) to the selected STN Service Center. 

If you are connected to a corporate network, more information may be needed to connect 
through a gateway, firewall, or proxy. If you select this option, the wizard will ask you 
about this in the next step. 

• Dial-Up Networking – This uses the Dial-up Networking feature of Microsoft Windows to 
establish a dial-up connection to the Internet through an Internet Service Provider. This is 
not a common selection. 

• SSL-VPN – This option uses HTTP over an SSL (Secure Sockets Layer) connection to 
create a VPN (Virtual Private Network) to STN. It assumes that you have a Constant 
Internet Connection, as described above and you must have a current version of Oracle® 
Java™ installed on your computer.  SSL/VPN uses a small Java applet to create and 
maintain the encrypted connection. 
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The SSL-VPN connection will be established between your web browser and the STN Service 
Center. This has two advantages over a constant Internet connection: 

o The connection is encrypted 

o An HTTPS connection is less like to be blocked by a corporate firewall than a telnet 
connection. 

6. Click the appropriate radio button, and then click Next.  

If you selected: 

• Internet Connection – you will be asked to logon using a Gateway, Firewall, or Proxy 
Server. Check with your IT team as to whether this is necessary. 

 

If Yes: 

a. Click the Yes radio button. 

b. Enter the server address. If you are automatically routed to the server, then use 
the Host name or IP address supplied by Express. 
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c. Click Next. 

d. Enter the necessary system prompts and responses supplied by your IT 
department.  
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e. Save your Setup by entering a Setup Name. (Optional) Enter your STN Login 
ID and Password with your Setup to avoid entering it when you login. 
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f. Click Finish. 

If No: 

a. Click Next. 

b. Save your Setup by entering a Setup Name. Use descriptive text, such as STN-
CAS or STNC-SSL/VPN. 

c. (Optional) Enter your STN Login ID and Password with your Setup to avoid 
entering it when you login. Your password will be encrypted when it is saved. 

 
d. Click Finish. 
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• Dial-Up Networking –  

 

a. Prior to selecting this choice, configure a Dial-up network. 

b. Select the Dial-up Connection from the drop-down list (active when network is 
configured). 

c. Click Next. 
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• SSL-VPN –  

 

a. Save your Setup by entering a Setup Name. Use descriptive text, such as STN-CAS 
or STNC-SSL/VPN. 

b. (Optional) Enter your STN Login ID and Password with your Setup to avoid entering 
it when you login. Your password will be encrypted when it is saved. 

c. Click Finish. 
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How can I modify or create an STN Express logon setup? 
Use the STN Setup program to modify a setup or create a non-STN setup.  

To modify an STN Express logon setup:  

1. Click Setup on the main toolbar, and then choose Connections.  

 

– Or –   

Click the Setup  icon on the main toolbar. 

 

2. Choose the Setup name, and then click Modify (click New to create a new logon setup). 

 



 
 
 

14 
 
 

www.cas.org 
www.stn-international.com 

3. Use the following to modify the current setup. 

 

 
Change the name of your setup. The name can be up to 20 characters in length, including 
spaces. 

 
If you saved your STN password in your setup, but changed your password while online, 
be sure to save the new one in your setup. 

 
Use the Host Settings tab to set online host-specific information, including the STN port 
letter. 

 
If you encounter problems connecting to STN-Columbus using the Host Name 
(stnc.cas.org), enter the IP Address (134.243.5.32). Both the Host Name and IP Address 
can be found in the drop-down list. DNS names and IP addresses for STN FIZ-Karlsruhe 
are also available. 

 
Click Advanced to update firewall or gateway information. 
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Click OK to accept the modifications or Cancel to discard them. 

Note:   

Communication Settings: The default option is to use (checked) “Encryption provided by RSA” in order to 
encrypt the contents of your telnet connection to the STN server and enhance your search security. 
However, some firewalls will not allow encrypted telnet. If you experience dropped session connections, 
try unchecking the “Encryption provided by RSA” option. As an alternative, you may wish to create an 
SSL/VPN setup. 

To modify a Winsock/Internet Setup (Advanced Dialogue: Gateway Configuration):  
The gateway login and connect-to-STN Columbus procedure is as follows. (The gateway's prompts are 
shown using a regular font, and example responses are shown using italics) 

Login:User> 

Password: Password> 

Command: =>  

Execute at command prompt: telnet stnc.cas.org 
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If your gateway asks for a login ID, type the login prompt in the Login box. This entry is case 
sensitive. 

 
If your gateway asks for a password, type the password prompt in the Password box. This 
entry is case sensitive. 

 
If your gateway displays a prompt when it's ready to accept a command, type the prompt in the 
Command box. This entry is case sensitive. If your gateway does not display a prompt, enter 
an X in the box. 

 
If you must provide a login ID to the telnet gateway, type it in the Gateway Login ID box. If you 
do not enter it, STN Express will ask for it during the gateway login each time. 

 
If you must provide a password to log on to the gateway, type it in the Password box (under the 
Optional section). If you do not enter it, STN Express will ask for it during each gateway 
connection. If you do type it here, it is encrypted and saved on your hard drive. 

 
In the first Execute at command prompt box, type the command that connects you to STN. In 
this example, the command is simply the STN Columbus host name, stnc.cas.org preceded by 
“telnet”. The equivalent IP address, 134.243.5.32, should also work. 

 
Click OK to save your changes or Cancel to discard them. 
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The default STN Port letter X is suitable for most accounts. If you have been instructed to use a 
different port, type the letter in the STN Port box. Customers in the CAS academic program can 
also use the port for their North American time zone: 

Time Zone STN Port Letter 
Eastern I 
Central C 
Mountain M 
Pacific Z 

 

 
Uncheck Close Window at logoff if you would like the session window to stay open after you 
finish your online session. 

 
Check Command Window if you want STN Online and Results to open a command window 
each time you log on. 

 
Click OK to save your changes or Cancel to discard them. 
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How can I establish a secure connection to STN? 
STN Express 8.4 and newer can use SSL-VPN to make the connection from your computer to the STN 
Service Centers. This option downloads a small java applet which runs in your web browser to create a 
VPN (Virtual Private Network) tunnel using SSL (Secure Sockets Layer). Your STN Express client 
communicates with your web browser and all STN Express traffic is sent and received through the secure 
VPN Tunnel. SSL-VPN is available for connections only to the STN Service Centers, not to other 
database suppliers. 

To set up a secure and encrypted connection to STN via SSL-VPN:  
Configure STN Express: 

1. Ensure that a current version of Oracle® Java™ is installed on your computer. 

2. Launch STN Express, but do not log into the application. 

3. Click Setup on the main toolbar, and then choose Connections.  

 

– Or –   

Click the Setup  icon on the main toolbar. 

 

4. Click New to create a new logon setup. 

5. Enter the following in the Setup Definition dialog box:  

• Setup Name:  SSL-VPN (used in this example) 

• Host Name:  STN-Tokyo or STN-Karlsruhe or STN-Columbus 

• Connect via:  SSL-VPN 

• Logon Method:  Standard (Winsock) (set automatically) 

• Host Name:  localhost (set automatically) 

• Port:  55555 (set automatically for STN-Tokyo or STN-Columbus); 

    6000 (set automatically for STN-Karlsruhe) 
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6. Click OK to exit the setup creation window.  

7. Click Save in the STN Setup window. 

8. Click OK to exit. 

 

Establish a secure and encrypted communication with STN 

1. Click Web on the main toolbar, and then choose STN Columbus, or STN Karlsruhe, or STN 
Tokyo. 

 
 

2. Choose STN [Host Name] Secure Connection. 

3. Select the STN Service Center you want to connect to. (STN Karlsruhe users will not see this 
prompt.) 

4. Confirm any security warnings and accept all certificates in order to install and execute the Java 
applet. 

5. Wait until the secure connection is established. A separate small status window reports the status 
of connection. A green flashing signal confirms successful connection. Leave the status window 
open for the duration of your STN Express session. 
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6. Return to STN Express and click the Logon  icon. 

7. Select the SSL-VPN setup in the Select Logon Settings window. Click OK to log on using the SSL 
VPN connection. 

Note:  

If you have logged on to STN and the session manager window Sent and Received packets remain at 0 
bytes, you did not log on using the SSL-VPN setup and your session is not being encrypted. Log off from 
STN and log on again using your SSL-VPN setup. 

Note:  

STN Express 8.4 and higher support automated SSL-VPN login. In those versions, click the Logon icon 
and then select the SSS-VPN setup from your list of setups. 

If you find that your STN session times out before the SSL/VPN session manager window appears, 
use the method detailed above to begin with the SSL/VPN session. 

SSL-VPN tips for optimal use 
• While RSA encryption can be used with an SSL-VPN session, it is recommended that you choose 

one or the other as each accomplishes the same thing – a secure and encrypted session. Using 
both together will cause the data being sent back and forth from your PC to the STN host to be 
doubly encrypted and could cause a degradation of service. 

• Within your browser, it is recommended that you check don't reuse the browser window to keep 
from accidentally overlaying the session manager window and accidentally terminating the 
connection. 

• The SSL-VPN connection to STN relies on the secure session manager running in the web 
browser window. This window is labeled: DO NOT CLOSE – Secure Application Manager. If this 
is the last active web browser window used and you click on a link from another application 
(including STN), you may get a dialog that asks: Are you sure you want to navigate away from this 
window? If you respond Yes, your SSL-VPN connection is disconnected along with your STN 
session. In your STN window, you will see a message: Connection closed by remote host. 

• If you click End Session within the secure application session manager window, this will end your 
SSL-VPN and STN sessions. 
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Connectivity problems 
Possible reasons for encountering problems establishing the SSL-VPN session: 

• The HTTPS protocol may be blocked. Confirm that port 443/TCP is permitted through your firewall 
and/or proxy server. (To test this, try going to an https web-site to confirm it works, e.g., 
https://stnweb.cas.org .) 

• You have a pop-up blocker enabled within your browser preventing the session manager window 
from launching. In order for the SSL-VPN session to connect, you can either turn off your pop-up 
blocker, or add *.cas.org and/or *.fiz-karlsruhe.de as a trusted web site and allow for pop-ups. 

o Microsoft Internet Explorer: Choose Tools > Pop-up Blocker > Pop-up Blocker 
Settings and add *.cas.org and/or *.fiz- karlsruhe.de to the "Address of web-sites to 
allow". 

o Firefox: Choose Tools > Options > Content and click Exceptions to the right of 
Block pop-up windows and add *.cas.org and/or *.fiz-karlsruhe.de. 

• The web page has been cached and thus instead of running the program that launches the 
secure application manager session, it redirects you to: 

http://www.cas.org/ONLINE/STN/stnconnect.html  or http://www/stn-international.com/sslvpn.html 

Within a browser window: 

• Choose Tools > Options and click Delete Files in the Temporary Internet Settings section to 
clear the cache. 

• In the Temporary Internet Settings section, click the Settings button and check Every visit to the 
page (for IE). 

• Finally, close all browser windows and then within STN Express, choose Secure Session from 
the appropriate service center within the Web menu and that will allow you to establish a new 
SSL-VPN session. 

  

https://stnweb.cas.org/
http://www.cas.org/ONLINE/STN/stnconnect.html
http://www/stn-international.com/sslvpn.html
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Why can’t I login to CAS Registry BLAST? 
If you are not able to log on to CAS Registry BLAST, or if your computer cannot connect to the BLAST 
server, an error message appears: 

 

The problem can often be corrected by setting proxy server preferences for CAS Registry BLAST. 
Unlike browsers, the BLAST client will not automatically detect and use a proxy. It must be manually 
added. 

Determine the Proxy Server 

Your IT department or internal help desk is best-equipped to tell you if you should use a proxy server and, 
if so, which proxy server you should use. However, if your web browser is configured with a proxy server, 
you can try using the same information for CAS Registry BLAST. 

You will need to know the following settings for the proxy server: 

• the proxy server's name or address 

• the proxy server's port 

• whether the proxy server is an HTTP proxy or a SOCKS proxy 

To find your web browser for proxy server information, see View Proxy Settings in Microsoft Internet 
Explorer. 
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View Proxy Settings in Microsoft Internet Explorer 

1. Click Tools > Internet Options to open the Internet Options dialog box. 

 

2. Click the LAN settings button on the Connections tab. 
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If any boxes under Automatic configuration are checked, click Cancel. Ask your IT 
department or internal help desk for the name or address and port of your proxy server used 
for HTTPS/SSL connections. 

 
If the Use a proxy server for your LAN box is checked and the Address box is populated, 
note the Address and Port for use in BLAST. The type of proxy server is HTTP. 

 
If there is no entry in the Address box, click the Advanced button to check for more 
information in the Proxy Settings dialog box. 

3. In the Local Area Network (LAN) Settings dialog box, check only the Use a proxy server for your 
LAN box. 

4. Click the Advanced button. 
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If entries appear in the Socks boxes, then use these as your BLAST proxy settings. You 
have a SOCKS proxy server. 

 
It is possible that different proxy servers are used for HTTP and Secure connections.  If 
entries appear in the Secure boxes, then use these as your BLAST proxy settings.  The 
type of proxy is HTTP. 

 
If no entry appears in the Secure box, use the name or address and port displayed in the 
HTTP boxes. The type of proxy is HTTP. 

 
Click OK to accept the settings or click Cancel to close the dialog box. 

5. Define your settings (Proxy server’s name or IP address and the Port) based on the 
recommendations described above and click OK.  

6. Open STN Express version 8.4 or newer. 

7. Click Preferences!. 
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8. Click the BLAST® tab and then enter the following information: 

• Select type of firewall – HTTP (including HTTPS or secure) or SOCKS 

Note: SOCKS 5 authentication is not supported. SOCKS 4 or SOCKS 5 without 
authentication should work. 

• Proxy’s Settings – enter the proxy server's Host-name or IP address 

• Server port – enter the proxy server's communication port number 

 

9. Click OK to close the Preferences dialog box and save the settings. 

10. Click File > Exit STN Online and Results or click X to close the BLAST application. 

11. Click File > Exit STN Express or click X to close the STN Express application. 

12. Open STN Express and log into CAS Registry BLAST. 
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What are STN Express support files? 
 
The support files are used by STN Express functions such as display, reports and tables, dictionaries and 
more. Support file updates are issued to match changes in STN databases, including addition or removal 
of databases or enhancements to display formats. Updating to current support files ensures that you have 
the best STN Express experience and value. 
 

Support File Name Content or Function 

ABBREVE.INI Controls expanding of abbreviations in the Online Window and transcripts in 
the following fields: Abstract, Title, Supplementary Terms, Controlled or Index 
Terms. 

cn.bt 

cn.ff 

Updates to Company Name Thesaurus. 

discover.fil List of STN Files and their features for the STN Database Selection Wizard. 
List of valid STN AnaVist Files and their DISPLAY cost estimates. 

FIELD.COD Field details for Tables and Reports. Contains one entry for every DISPLAY 
field name and field heading, e.g., TITLE, TI. 

Journals.txt List of Journals for the SDI TOC Wizard 

lexicon.bt 

lexicon.mp lexicon.st 

Updates to CA Lexicon. 

Links.txt Parsing rules for all hyperlinked DISPLAY fields such as patent information 
fields. 

SGML.INI For display of Tables and Reports. 

SUFFIXES Used for company name groupings 

URL.INI URLs used by STN Express 
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What can I do if automatic updating of support files does not 
work? 
What is automatic updating? 
STN Express support files may be updated between STN Express software releases. The support files 
contain information used by the STN Express wizards, search aids, and post- processing tools. The 
information includes: 

• The list of STN files and their characteristics 

• The company name thesaurus used in the Analyze Plus Wizard 

• The terms in the CA Lexicon used by the CA Lexicon Search Aid 

• Information to identify fields in transcripts for the Table and Report tools 

The updated support files are made available to STN Express V8.4 and newer via Automatic File 
Updates. The first time STN Express is run each day, it checks for updates to the support files. If new 
support files are found, a pop-up dialog provides the option of downloading and installing the files 
immediately or when STN Express closes. 

Automatic updates may take from 15 seconds to several minutes depending upon: 

• Your Internet connection speed (bandwidth) 

• Your computer processing speed 

• The number of files available for automatic update 

What can I do if automatic updating does not work? 
STN Express uses the HTTP protocol to check for updates and to download the updated support files. If 
automatic updating fails on your PC, it may be because of the proxy settings for your system or in STN 
Express. 

Step 1:  Check Your Proxy Configuration 

1. On your computer, click Start > Control Panel > Internet Options. 

2. Click the Connections tab, and then click the LAN settings button. 

3. If the options in the Automatic configuration section are: 

• Not checked – continue to Step 3 

• One or both are checked – contact your IT group to determine if they can both be 
unchecked.  If the answer is: 

o Yes – uncheck all selections and continue to Step 3. 

o No – Ask your IT group if you can specify a proxy server and port in STN Express. 
Enter the values and continue to Step 2. 
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If one of the Automatic configuration options must be checked and you cannot specify a proxy server 
and port, automatic updating will not work. To prevent STN Express from attempting to do automatic 
updating, see Turn Off Automatic Updating. 
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Step 2:  Change STN Express HTTP Proxy Settings 

This option works only in STN Express 8.4 

In STN Express  8.4, the HTTP Proxy Settings defined in the BLAST tab of the User Preferences 
overrides the Local Area Network (LAN) Settings.   

1. Start STN Express, and then select Setup > Preferences > STN Online and Results.  

2. Click the BLAST® tab and then enter the following information: 

• Select type of firewall – HTTP 

• Proxy’s Settings – enter the Host-name (name or IP address) and Server port provided 
to you by your  IT group 

 

3. Click OK to close the Preferences dialog box and save the settings. 

If the automatic updating works, then you are done. If not, continue to Step 3. 
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Step 3: Turn off BLAST Proxy Settings 

In STN Express, version 8.4 only. 

STN Express uses the BLAST HTTP Proxy Settings for automatic updating even if Select type of firewall 
is set to None or Socks. If either of these is selected, the Host-name and Server port are not displayed. 

If necessary, remove any Proxy Settings values: 

1.   Choose HTTP for the Select type of firewall. 

2. Remove any entries in the Host-name (name or IP address) and Server port locations. 

3. Click OK to save these changes. 

4. Open the user preferences to the BLAST tab again. 

5. Choose None for the Select type of firewall. 

6. Click OK to save this value. 

If the automatic updating works, then you are done. If not, continue to Step 4. 

 

Step 4: Use of HTTP 1.1 

If the proxy settings are correct and automatic updating still does not work, the version of HTTP used by 
your system may not be supported by the proxy server. HTTP 1.1 is preferred and is set using the Internet 
Options control panel. 

1. On your computer, click Start > Control Panel > Internet Options. 

2. Click the Advanced tab. 

3. Navigate to the HTTP settings section, and then select Use HTTP 1.1 through proxy 
connections. 
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4. Click OK and try automatic updating again. 

If the automatic updating works, then you are done. 

If automatic updating does not work, do one of the following: 

• Turn off automatic updating 

a. Start STN Express and click the Prefs   icon on the main toolbar. 

b. Choose STN Online and Results from the drop-down menu. 

c. Click the Other tab. 

d. Check the option Shut off automatic updating of support files. 
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• Contact CAS Customer Center for additional assistance 

• Manually download the support files  

http://www.cas.org/contact-us/cas-customer-center
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How can I update STN Express support files manually? 
How are STN Express support files updated? 

Starting with STN Express 8.4, the application checks for updated support files at log in. If updates are 
found, STN Express downloads and installs the new support files. If automatic updating has been 
disabled, you have two methods to manually update support files. 

Update using the EXE Method (STN Express 8.4 and newer versions): 

If you have taken the default settings for user file location as My Documents, then the EXE (executable) 
file method is recommended. The installer will perform the update for you. 

1. Exit your current session of STN Express. 

2. Download the EXE file from the STN Express support site. 

3. Run the executable file and respond to the prompts. 

4. Restart STN Express. Support files will be updated at the first restart of STN Express. 

Update using the ZIP File Method (STN Express 8.4 and newer versions only): 

This method requires a hands-on user for those with non-default locations for user file folders. 

1. Download the ZIP file from the STN Express support site. 

2. The contents of the ZIP file need to be placed in the \Data folder of your STN Express installation. 
For versions 8.4 and newer, that is generally in your My Documents folder in Windows XP or in 
the Documents folder for newer operating systems. 

a. Start STN Express, and then click the Prefs  icon on the main toolbar. 

b. Choose  General from the drop-down menu. 

c. The path listed in User Scripts can be used to navigate to your \Data folder. 
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1. Click OK, and then close STN Express. 

3. Unzip the files 

a. Use WinZip or any other file extraction tool compatible with WinZip files. 

b. Extract the zipped files into the \Data folder and accept over-writing files with the same 
name. 

In the example shown, the path would be: 

\\cas\cr\desktopFR\cmm88\Documents\STN Express 8.6\Data  

This system uses Windows 7 folder redirection.   

Your path without folder redirection may be: 

C:\Users\cmm88\Documents\STN Express 8.6\Data 

4. Restart STN Express. 
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How can I import a mol file? 
The STN Express structure drawing tool will open structure files in a variety of formats: 

• *.cxf - Chemical Exchange Format 

• *.drc – DARC Format 

• *.mol – MDL Molfile 

• *.rxn – MDL Reaction 

• *.smd – SMD Format 

• *.alc – Alchemy Molfile 

1. Open STN Express and click the Prepare Query  icon. 

2. In the Structure Drawing window, click File > Open. 

3. Select the desired input format from the Files of type drop-down list. 

4. Select the file of interest. 

5. Click the radio button for the desired target format under Convert to. 

6. Click Open. 

The converted structure will be opened in a new Untitled window. The original structure file will not be 
changed. 
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Because of differing conventions, information may be lost in converting from one file type to another. 
Always verify the results of the conversion. 
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How can I save a query as a mol file? 
The STN Express structure drawing tool will save structure queries in a variety of formats: 

• *.cxf - Chemical Exchange Format 

• *.drc – DARC Format 

• *.mol – MDL Molfile 

• *.rxn – MDL Reaction 

• *.smd – SMD Format 

• *.smi – SMILES Format 

• *.wmf – Windows Metafile 

 

1. In the Structure Drawing window, click File > Save As. 

2. Enter a name into the File name location. 

3. Select the desired input format from the Files of type drop-down list. 

4. Click Save. 
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Because of differing conventions, information may be lost in converting from one file type to another. 
Always verify the results of the conversion. 
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How can I preserve formatting of my table or report for future 
use? 
The STN Table and Report tool allows you to customize a table or report. Use the Save Template feature 
to save the format. 

Set the combination of fields, formatting, and features that you want, and then click the Save Template 
button in the Report Tool or Table Tool window. A file chooser opens where you can enter a name for the 
template prior to saving. 

 

To use the template when creating a new report, click the Template button, select the desired template, 
and then click the Choose Template button. 
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What does the "Remove duplicate fields within an answer" 
option do in the Table or Report Tool? 
Click the Fields button in the STN Express Table Tool or Report Tool window to access the Remove 
duplicate fields within an answer option. If the option is: 

• Unchecked – the option is disabled (off) 

If a display contains multiple instances of a field, STN Express will collect all of the values into a 
single cell (in a Table) or under a single heading (Report). For example, if a Registry record has 
multiple CN (Chemical Name) fields, all of the Chemical Names will be listed together. 

The Table or Report tool will do the same thing if a record contains fields which the Table or 
Report tool considers to be equivalent. For example, if a record contains the TI, TIEN, and TIJP 
fields, the values of those fields will be listed together. 

• Checked – the option is enabled (on) 

When Remove duplicate fields within an answer option is turned enabled, the Table or Report tool 
collects the related field values, as described above, and removes duplicate values within each 
collection of values. 

Example 

A record contains the following fields: 

TI       Printing System. TIEN     Printing System. TIDE     Drucksystem. 

TIFR     Systeme d'impression. 

• Remove duplicate fields within an answer is disabled (off), the Report contains all four field 
values: 

Title 

Printing System. 

Printing System. Drucksystem. 

Systeme d'impression. 

• Remove duplicate fields within an answer is enabled (on), the Report does not contain 
duplicate values: 

Title 

Printing System. Drucksystem. 

Systeme d'impression. 

 

Review the steps above. If you need assistance, contact your STN Service Center. 
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What special features does the Table Tool or Report Tool 
have for patent information? 
The STN Express Table or Report tool formats fields from any STN file. Several fields containing patent 
information have special formatting options. 

Patent Information Fields 

Several fields contain information about patents displayed in a table format. The columns of each table 
contain specific data values, such as Patent Number, Kind Code, and Date. The rows in each table 
represent individual documents, such as patents or patent applications. 

Formatting Options 

The Table or Report tool formats these fields either as a table or as the individual data items extracted 
from the table. The field name you choose in the Fields section of the Table or Report tool determines 
how the data is formatted: 

Field Label in Display Select This Field Name To . . . 

Format as Table Format Individual Items 

AI Application Information Individual AI 

PI Patent Information Individual PI 

PRAI Priority Application Information Individual PRAI 

When any of these fields is moved to the Selected Fields column and highlighted, two additional tabs 
appear in the formatting options section. These tabs allow you to select the data (rows and columns) to be 
included in the table or report. 

1. Columns (data values) are chosen on the Subfields tab. 

2. Rows (documents) are chosen on the Other tab. 

Choosing Documents on the Other Tab 

On the Other tab, you specify the maximum number of rows to display in each answer. Within that limit, 
you select the specific countries to include. 

1. Maximum number of rows per answer 

a. The Only first nn or Maximum…rows per answer options will set an upper limit on the 
number of documents to be included in each answer. 

b. The All option (when available) will include all of the documents (no upper limit) 

2. Selected countries lets you select the countries for which patent information will be included. 
The list will contain all countries included in the current transcript. 

a. Selecting “All Countries” will include all countries in the list 

b. To select individual countries, hold down the Control (Ctrl) key while clicking on the 
countries to include. 
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General Rule 

Before using an STN Express report template, we recommend that you review the options selected to 
ensure they are appropriate for the task.  
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What can I do if structure diagrams don’t appear in my 
transcripts? 
Depending on your preference, STN Express captures transcripts in its native .trn format or in Rich Text 
Format (.rtf). This document applies to .trn transcripts. If chemical structure diagrams are missing from a 
transcript that was captured as RTF, contact CAS Customer Center. 

STN Express transcripts that contain structure diagrams are stored in two files. One file, with a .trn 
extension, contains the text of the transcript. The other file, with a .gra extension, contains the graphic 
(structure diagrams) part of the transcript. You provide the name for the files when the transcript is 
created. For example, if you name the transcript registry.trn, then registry.trn contains the text part of the 
transcript, and the file registry.gra contains the structure diagrams for the transcript. 

View and print structures in Browse Transcript 

The STN Express Browse Transcript feature knows how to combine the text and graphics transcript files 
and display them as one. If there are structure diagrams in your transcript, you'll be able to see them 
using Browse Transcript. Also, if you see structures while browsing, they'll be printed when you print from 
Browse Transcript. 

Structures in STN Edit 

If you edit a transcript using the built-in STN Express text editor or any other text editor, no structures are 
visible. Instead, in the place where a structure diagram should appear, there is a reference to the .gra file.  

For example: 

=> d l1 

L1 ANSWER 1 REGISTRY COPYRIGHT 1998 ACS RN 168023-31-2 

REGISTRY 

/ Structure 1 in file .gra / Do not modify this line! 

The text editor does not know how to combine the two transcript files, and only the text is displayed. 
Because no structures are visible, if you print the transcript from STN Edit no structures are printed. 

Why might the chemical structure diagrams be missing from STN Express .trn 
transcripts? 
The chemical structure diagrams will not show up in the .trn transcript if: 

• The text and graphics files do not have the same name (except for the .trn and .gra extensions) 

• The text (.trn) and graphics (.gra) files are not in the same folder 

• The references to the .gra file were changed in the .trn file 

  

http://www.cas.org/contact-us/cas-customer-center
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How can I get transcripts and structure diagrams into a 
single file? 
Exporting transcripts with structures 

To get a transcript and the associated structure diagrams into a single file, use the STN Express Save As 
feature to save the transcript as an RTF (Rich Text Format) file. This will allow you to view and edit the 
transcript, with structure diagrams, in your word processor. 

1. Click the Browse Document  icon on the main toolbar. 

2. Choose the transcript of interest, and then click Open. (The name of the most recently used 
transcript is automatically selected.) 

 

3. Review the transcript. Make sure the transcript contains the expected information and that 
structure diagrams are present. 
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4. To create the new document, click File > Save As. 

5. Navigate to the folder where you will save the file, and then type the name of the new document 
into the File name box (or accept the default name).  

6. Click Save.  

When the transcript is exported successfully, your word processor opens or a message is 
displayed, depending on the selections defined in the system Preferences. 

 

7. Click OK at the <>.rtf created successfully system prompt. 
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What if there are still no structures in the transcript? 

• Are structure diagrams displayed when Browse Transcript is used to view the .trn version of the 
transcript? If they are not, see the FAQ on what to do if structure diagrams are missing from your 
transcripts. 

• Were there error messages from the export transcript process? 

• In Microsoft Word, there is a preference that replaces images with placeholders. Click Tools > 
Options, and then select the View tab. Be sure that the Picture placeholders option is 
unchecked. 

If you have any questions about viewing chemical structure diagrams in an STN Express transcript, 
contact CAS Customer Center. 

  

http://www.cas.org/contact-us/cas-customer-center
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How can I save my answers for import into Endnote or 
Reference Manager? 
Answers with bibliographic information obtained within STN Express may be saved into a text formatted 
file that can be used as a source for importing bibliographic and other information into the most frequently 
used bibliographic management programs. 

Answers must be saved in a particular format of a text file known as Tagged Text. That format has the 
field names in a left column in the file followed by a space or a tab character, and then the field 
information. 

Examples: 

Figure 1 - Example Tagged Text File – 2-Letter Field Codes 

 
 

Figure 2 - Example - Tagged Text File - Full Field Codes 
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The bibliographic information managers all have import filters that can perform field mapping of the data, 
using that file type, from the tagged text file into the bibliographic program database. 

• Filters for STN – CAS are supplied with each of the cited programs. 

• Each program has a built-in filter editor that may be used to customize the field mapping. 

• EndNote and Reference Manager technical support will provide assistance with using, creating 
and editing filters for their respective software programs. 

This guide provides a method for generating a suitable Tagged Text import file from STN Express. 

Choose Transcript Type When prompted for a transcript file, use the STN Express, native 

*.trn file format. You may capture a transcript from the beginning of 
the session or toggle capture ON later. 

Display There are several display formats that lend themselves to 
conversion into Tagged Text files. For example: 

• BIB or BIB ABS, if you want the abstract: This format uses 
2-letter field identifiers.  See Figure 1, above. 

• IBIB or IBIB ABS: this format uses the full field identifiers, 
such as TITLE:, AUTHOR(S): See Figure 2, above. 

• DALL: This is the ALL format, delimited for post- processing 

None of the compressed formats, e.g., CBIB will work. Field codes 
must start each line and each line must be a separate unit: 

Field Code – separator – Field Data 

Most STN bibliographic import filters are constructed using the Two-
Letter field codes, but you can edit the filter to use full fields or 
create a new filter for Full Field Names. 

Browse Transcript and  
Apply Filter 

STN Express has several transcript file filters; the ANS (Answers) 
filter will process a raw transcript file and strip out non-answer data. 
The output of the filter process will be a “clean” file (see Figure 1, for 
example), yielding a file that is ideal for import processing. See the 
following page for detailed steps. 
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Filtering Transcripts: 

1. Click Browse Transcript to open the transcript file. 

2. In the STN Online and Results window menu, select File > Transcript filters, enter a new file 
name, and then click Save. 

 

3. Use the following Specify Filter settings: 

 

4. Click OK to run the filter process and save the filtered file. 

5. Click OK at the <>.trn created successfully system prompt. 
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6. Select Browse Transcript or Edit Transcript to view or edit the new filtered file. 

 

Convert Transcript to a Text file: 

Use one of the following two methods to convert the transcript to a text file: 

Method A:  EDIT TRANSCRIPT 

The filtered transcript file will still contain a header line, 

$%^STN;HighlightOn= ***;HighlightOff=*** ;Version = STN Express 8.x  

The import filter will generally ignore that line; however, it can be removed using Edit Transcript. 

1. Open the file in Edit Transcript. 

2. Perform any desired edits. 

3. Click File >Save As from the STNedit window menu. 

4. Navigate to the folder where you will save the file, and then type the name of the new 
document into the File name box. 

5. Choose Text Files (*.txt) as the Save as type.  

 
6. Click Save. 
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Method B:  BROWSE TRANSCRIPT 

1. If you have the file open in STN Express, save the file and close the Browse Transcript 
window. 

2. Using Windows Explorer, locate the saved file. 

3. Edit the file extension from .trn (Transcript) to .txt (plain ASCII text). 

The file is now ready for use as an import file in: 

• EndNote 

• Reference Manager 

At this juncture the file may be opened and edited in any text-based program, such as WordPad, 
NotePad or Microsoft Word if further editing or refinement is needed. 

If you experience problems during the import process or if you need assistance with import filter 
editing, please contact the technical support team for your bibliographic management program. 

EndNote:  http://endnote.com/support 

Reference Manager:  http://refman.com/ 

  

http://endnote.com/support
http://refman.com/
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How do I move my STN Express files and settings to a new 
computer? 
To migrate your STN Express logon setups, queries, or transcripts to a new computer, use the following 
process:  

Organize the information on your current computer 

If your current computer is running STN Express V8.2 or earlier, install the current version of STN 
Express. This will copy the important files to the locations used by the current version of STN Express, 
which will make it much easier to copy them to your new PC. 

You can skip this step if your current computer is already running STN Express V8.4 or later. 

Install the current version of STN Express on your new computer 

This will give you the most current features of STN Express. 

Copy the important files to your new computer 

1. On your current computer, locate the STN Express folder in the Documents library (use the most 
current version of the application). Select all the files and folders in this location. 

2. On your new computer, locate the folder Documents library containing the STN Express files. 
Copy the files and folders selected in Step 1 to this folder, replacing any duplicates. 

      

If you cannot copy files and folders directly from your current computer to your new computer, copy them 
to an intermediate location (network storage, CD, DVD or flash drive) first. Then copy them to your new 
computer. 
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